Connect an USB disk and open Disk Utilities
Optionally partition the USB disk with multiple partitions (assuming /dev/disk4 is your usb disk):
diskutil list
diskutil erasedisk hfs+ External GPT /dev/disk4
Create a partition of 8GB for macOS Ventura and/or 16GB for macOS Big Sur
In the Terminal, run:
sudo /Applications/Install\ macOS\ Ventura.app/Contents/Resources/createinstallmedia --volume /Volumes/<Your USB disk>
Restart your Mac and hold the ⌘R key combination
From the Appstore:
From their own website:
Confluence gets its preferred language from the browser:
Fix home & end keys to go to the beginning and end of a line:
mkdir ~/Library/KeyBindings
vi ~/Library/KeyBindings/DefaultKeyBinding.dict
{
"\UF729" = "moveToBeginningOfLine:"; // home
"\UF72B" = "moveToEndOfLine:"; // end
"$\UF729" = "moveToBeginningOfLineAndModifySelection:"; // shift-home
"$\UF72B" = "moveToEndOfLineAndModifySelection:"; // shift-end
"^\UF729" = "moveToBeginningOfDocument:"; /* Ctrl + Home */
"^\UF72B" = "moveToEndOfDocument:"; /* Ctrl + End */
"$^\UF729" = "moveToBeginningOfDocumentAndModifySelection:"; /* Shift + Ctrl + Home */
"$^\UF72B" = "moveToEndOfDocumentAndModifySelection:"; /* Shift + Ctrl + End */
}
vi ~/.zshrc
bindkey "\033[1~" beginning-of-line
bindkey "\033[4~" end-of-line
In iTerm2 > Preferences > Profiles > Keys
Esc+: [1~
Esc+: [4~
Set correct hostname:
scutil --set HostName "<my computer name>"
Install Brew:
/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"
Setup xcode (already done by Brew):
xcode-select --install
Download and install powerline font
git clone https://github.com/powerline/fonts.git
cd fonts
./install.sh